По-арабски слова пишутся справа налево, а цифры — слева направо. Владеющие арабским языком при чтении текстов, изобилующих цифрами, вынуждены читать в обе стороны одновременно.

Очень часто руководители компаний просят предоставить статистику посещений сайтов своими сотрудниками. Этот вопрос легко решается при наличии развитой ИТ-инфраструктуры, путем установки дополнительного прокси сервера и организации на нем сбора статистики. Но что делать компаниям, которые не имеют или не готовы раздувать свою инфраструктуру «еще одной единицей» техники? В этой статье мы покажем пример использования сил только одного маршрутизатора mikrotik для решения задачи по сбору статистики посещений. Отчеты мы предлагаем формировать с помощью небольшой утилиты под windows — WebProxy-Log.

Далее по шагам:
— Открыть свой Mikrotik через Winbox.
— Зайти в IP => Web Proxy.
— Вкладка General.
— Установить галку рядом с Enabled.
— Указать порт 8080.
— Параметр Cache Administrator: на webmaster.
— Параметр Max. Cache Size: на unlimited.
— Параметр Max Cache Object Size: на 2048.
— Установить галку рядом с Cache On Disk.
— Параметр Max. Client Connections: на 600.
— Параметр Max. Server Connections: на 600.
— Параметр Max Fresh Time: оставить 3d 00:00:00.
— Параметр Cache Hit DSCP (TOS): оставить 4.
— Параметр Cache Path: на primary-master.

          

Нажимаем OK.
— Далее заходим в System => Logging.
— Вкладка Action.
— Нажимаем на +.
— Name: изменяем на WebProxyLog.
— Type: изменяем на remote.
— Remote Address: пишем адрес компьютера на котором установлена программа WebProxy-Log.
— Remote Port: оставляем 514 (порт udp).
— Нажимаем OK.



После чего наша настройка отразится во вкладке Action.


Переходим во вкладку Rules

— Нажимаем на +.
— Topics: выбираем web-proxy.
— Prefix: пишем Proxy.
— Action: выбираем WebProxyLog.
— Нажимаем OK.


Т. к. mikrotik при формировании логов делает очень много записей которые нам не нужны, мы добавим исключения. Добавим аналогично web-proxy правило со значением! debug (знак! определяет исключение).
После чего наша настройка отразится во вкладке Rules.


Теперь открываем New Termenal и пишем правило для NAT:
— /ip firewall nat
add action=redirect chain=dstnat comment=«Redirect port 80 request to Web Proxy» disabled=no dst-port=80 protocol=tcp to-ports=8080
— Открываем UDP порт под номером 514.
— chain=dstnat protocol=udp dst-port=514 action=dst-nat to-addresses=192.168.0.200 to-ports=514

Настройка Mikrotik завершена.
— Скачиваем программу WebProxy-Log.

— Устанавливаем и запускаем программу.
— В окне General settings указываем IP address: 192.168.0.200 (адрес компьютера).
— UDP Port: указываем 514.
— Buffer: указываем 400.
— Write log to: Указываем путь на каталог, где будет лежать файл журнала.
— Import from: Указываем путь на каталог откуда будет импортироваться файл журнала.
— Мои пути:
D:\Documents and Settings\god\Рабочий стол\
D:\Documents and Settings\god\Рабочий стол\New Folder
— DB location: этот путь мы оставляем по умолчанию.
— Устанавливаем галочку на Use insecure import.
— Устанавливаем галочку на Optimize database after log import.
— Нажимаем Apply.


— Далее заходим в File => Import logs.
— Снимаем галочку на Archive imported *.log files.
— Выбираем путь к файлу.
— Нажимаем Import.
— Соглашаемся со всем.


— Выбираем IP адрес в Select user:
— Выбираем дату с какого по какое в Select date range:
— Нажимаем кнопку Generate.

Получаем статистику, как показано ниже:

Уважаемые, а реально на RB751U поднять какой-нибудь прокси?
Дело в чём - на полугосударственной работе админы блочат 95% сайтов, которые требуются для решения вопросов по самой работе... самих админов никто никогда не видел, и им на всё пофиг - ничего не делают с качающими фильмы по ftp из интернета.
При попытке захода на сайты автоматический фильтр по какому-то своему критерию пишет "Games, porno, humor" и т.д. и не даёт зайти на безобидные сайты. При чем фильтр самообучающийся, и после нескольких минут на сайте может забанить его навеки. Надоело.
Если я куплю у провайдера внешний IP - каковы дальнейшие шаги для обеспечения интернета с работы через домашний роутер?
Спасибо.

  • 519 просмотров

Всем привет.
Подскажите кто-нибудь, приходилось ли сталкиваться с настройкой на Микротике
использования прозрачного внешнего прокси?
Это когда примерно следующая примерно конфигурация.
192.168.16.100 - локальный комп
88.89.100.101 - адрес внешней прокси
8080 - порт внешней прокси
80,443 - HTTP HTTPS
chain=dstnat action=dst-nat to-addresses=88.89.100.101 to-ports=8080 protocol=tcp src-address=192.168.16.100 in-interface=bridge dst-port=80
сюда же пробовали добавлять правило с макарадингом
/ip firewall nat
add chain=srcnat src-address=192.168.16.100\
dst-address=88.89.100.101 protocol=tcp dst-port=8080 \
action=masquerade
Таким образом ничего не работает, страницы - либо в таймаут, либо в ошибки валятся.
Либо работает только HTTP без HTTPS.
Так вот, заработает ли HTTPS при таком раскладе, или вообще никак?
HTTP вроде работает.

Нажмите, чтобы раскрыть...